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 Introduction  
 

If you don't know what SmashGP is it's an incredible homebrew GP32 and now 
PSP game that imitates Nintendo's Super Smash Brothers series. The graphics 
aren’t up to par with the Gamecube incarnation, but you could argue that the 
N64 version is uglier. The best part of SmashGP is the ability to make your own 
characters. This can be troublesome so that's why your here, I hope... Anyways 
Lets start this guide and if you have any questions, comments, or if you'd like 
me to add your website to the Sprite Resources part of this guide feel free to 
send me an Email to Drake250@gmail.com  

Any question? If so please ask them in this thread.   
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Step 1: Sprite Sheets and where to get them 
To make a character for SmashGP your going to need a Sprite Sheet, if you don't know what they are they 

are an image with a variety of poses of a certain character. You may or may not already have a sheet or 

two you'd wish to plop into SmashGP. For those of you who don't here are some resources. 

 

The Spriter's Resource - Fireball20xl's wonderful sprite collection. They used to have a MUCH bigger on 



but Psy had to get rid of it for hosting reasons. Still the best place to start when looking for sprites. 

 

The People's Sprites - Good collection of sprites from games and custom ones.  

 

The Shyguy Kingdom - Great website, and layout. 

 

GSA - Game Sprite Archives. Most of their sprites are split into each image which depending on who you 

are could be good or bad. 

 

sbd.neuropod.net Sprite Database, All around great place to look for sprites. They also have a limited 

selection of sounds.  

 

Google - Let’s face it, if you all out of places to go this is your best bet. 

Me! - I have a large collection of over 800 sprite sheets, so you can always email me to see if I have it. 

Step 2: Preparing the Sprite Sheet  
So you've got some cool sprite sheet ready. But you can use a sprite sheet in SmashGP. You’re going to 

need to split the sprites that fit SmashGP into their own image. First make sure you know who to get to 

MSpaint. If you don't go Start>All Programs>Accessories>Paint on most Windows operating systems. 

Paint is an important program in making each sprite. After you Open paint hit File>Open. Then navigate 

to where you saved the sprite sheets you want to edit. After the sprite Sheet is open you will need to get to 

know your tools of paint. 

 

This is the Select tool. It is used to make a rectangular box in which everything inside can me moved, 

resized, copied, cut, etc. 

This is the Free Form Select Tool. It works the same way as the regular Select Tool, except that you 

must draw a blob around what you want to edit. 

After you select which select tool you'll what to use you select the Transparency. The top one makes 

it so what ever the selected background doesn't matter. But, if select the lower option you will get it so the 

background color is transparent when editing. I will explain how to make the background color in the Pick 

Color Tool. 

This is the Eraser Tool, Basically whatever the background color is this will "erase" whatever it 

touches and change it to the background color. 

And this is the four options of how big the Eraser is. Bigger erases more, and vise-versa for smaller. 

This is the Fill With Color Tool. Basically whatever color you hit with this will change to the current 

color, along with surrounding pixels of the same color you first hit. 

This is the Pick Color Tool. This is what I refer to as the "eyedropper" because it looks just like one. So 

what this does is whatever pixel you select will make your current color that color. Also if you want to set 

a background color do as you normally would except right click instead of left clicking on the pixel you 

wish to absorb. 



This is the magnifier. This is essential When you want to edit a sprite. You just zoom in and all the 

pixels get bigger so you have less room for error when trying to move a leg, change a certain color, etc. 

Also the Magnifier has 4 different levels of zoom (or 5 if you don't select a level before zooming) I 

commonly use 8x because that's the best mode to use when you wan to edit every little thing. 

This is the Pencil, and personally I almost never use it because the Line's curser and use can do the 

same thing and more. 

This is the Brush. I consider this to be an odds and ends tool as it can do many weird little things. Like: 

These are all the different effects it does like bug squares and circles. 

This is the Airbrush. All it does is in a circle it randomly changes the colors to whatever the current one 

is. 

And these are the three different sizes of the Airbrush.  

This tool seems very primitive, the Text Tool. You basically make a box, and then Type something. It's 

so primitive because you can't go back and re-edit it. But it comes with Windows so what do you expect. 

This is the Line Tool. Probably my most used tool. The cursor is a crosshair which is very useful for 

knowing where you are going to edit. But what the Line tool is supposed to do is go from one point to 

another and make a line. 

This is just like the Line tool except when you make the line you click two more points. The original 

Line then "bends" to make it curvy near those two points. 

And as always you can select the line's thickness. 

This works just like Select Tool, except that the Rectangle stays there. 

All the rest of the Tools and the rectangle tool Use this. The top box is just a box outline. The middle 

is a Box and an outline, and the last is just the box. 

The Polygon Tool is more or less a continuous Line Tool. 

The Ellipse Tool basically makes a circle/oval of whatever size you want. 

The Rounded Rectangle is just as it sounds.  Ok, so now you know the tools of paint (unless you 

skipped all that) So now you need to learn how to put them into separate pictures and what each picture 

should resemble. To do this you're going to need two things. The SmashGP Character Editor and 

Irfanview. You need the Character Editor because you need to edit the character later, and so you can view 

what each moves looks like. Irfanview is essential for making the 8-Bit BMPs that are needed for 

SmashGP. 

 

Ok so you have your Sprites sheet up in paint right? Now you need to open another paint program up. This 



should launch a blank white sheet. Now go back to the original Sprite Sheet and hit Edit>Select All, then 

Edit>Copy. Then go back to the blank Paint document and go Edit>Paste. You now have made a copy of 

your sprite sheet. So go File>Save As. Name it whatever but make sure under Save as type: 24-bit Bitmap 

(*.bmp; *.dib). Now you need to use the Fill Color Tool. Select it and this color. This color is aqua, you 

should have it on your color toolbar: 

If not select a color and go Colors>Edit Colors and choose this color: 

 
Now use that color with the Fill Color tool to make the background of your sprites sheet Aqua. Aqua is the 

color SmashGP uses as a transparency. Now select File>Save. Now you have this 24-bit sprite sheet. You 

may think that this is unnecessary but this will make the colors of you 8-bit sprites much more lively. Ok 

now launch Irfanveiw. Select File>Open and navigate to the 24-bit sprite sheet you made. Now select 

File>Batch Conversion/Rename. This will bring you to something like this: 



 
Now make sure you select: Work as:>Batch conversion 

Batch conversion settings:>BMP - Windows Bitmap 

And most of all check Use advanced options, then click Set advanced options. 



 
That should bring you to a menu like this. Make sure the only thing checked is: CHANGE COLOR 

DEPTH: and select 256 Colors (8BPP), after that click OK.  Now add you picture to the blank box on the 

left hand of the screen. Select and output folder and select start. Now navigate to where you told Irfanview 

to output your file. Irfanview will have save your Sprite sheet as an 8-bit BMP but Irfanview makes better 

palettes than those of Paint. I will be covering the error in Irfanview because I get mixed reports of it but I 

personally get the error. When Irfanview converts to 8--bit BMPs sometimes and changes the aqua color to 

a different shade. To check open the newly converted Sprite Sheet in Paint. Now use the eyedropper on the 

background and hit Colors>Edit Colors. Now it will bring up a color menu if your color menu looks like 

this: 



 
Then that means that the color is not aqua, but close, however if your Edit Colors looks like this: 

 
Then it is aqua and you’re good to go, but incase it isn’t aqua you must do this: 

Close out of paint. 

Open The sprite sheet in Irfanview. 

Go click: Image>Palette>Edit Palette. That should bring you to something like this (the color will be 

different though): 



 
Now you'll be looking for the color that looks like Aqua. Normally it appears on the first two rows. 

Double Click on it. And you'll need to Change the values to this: 

 
After that your sprite sheet should be formatted correctly. 

Now comes the longest part (most times).  

Part 3: Turning One Sprite Sheet Into Many Sprites 
So now your Sprite Sheet is ready. Open it in Paint twice, One will be where you copy the sprites from. 

The other will be for each sprite. How you do this is to use the Select tool. Make a box around the sprite 

you want to separate and click Edit>Copy. Now go to the other sprite sheet and before you paste it. Go to 

the southeast corner of the sheet and shrink the sheet until it becomes extremely small. Now when you 

paste the sprite it should make the sheet larger so it touches each end of the picture. If you copied your 



sprite and left some aqua around him on all sides make sure to trim him from this: 

 
to this: 

 
See how the Elite's mouth, west, east, and south edges touch the edge of the picture? That's what you want 

to do. Do this with every Sprite you need to make. (if you don't know what sprites to make load Mario 

example in the CharEdit of the SmashGP Editor programs to see what Mario’s moves look like, or go 

here) When saving them, they must be in 256 color BMP format, the filename must also be six characters 

or smaller. The best way to do this is to name them like this: 

AAA##X.bmp 

 

AAA is the first three letters of the character's name. Example: if I were making Mario I would use his 

first three letters, mar. 

## is the number of the frame. Example: If I were making an Idle pose I would use the number 00, as 

move "Idle" is number 00. 

X is the frame letter. If I had two frames for a Move I would end the first frame in a, and the second in b.  

So If I made Sonic the Hedgehog’s Run Frame, and it was 3 frames long I would name the frames (from 

first to last): 

son02a.bmp 

son02b.bmp 

son02c.bmpFor Projectiles I use PR instead of a number. 

And for Icons use AAAICO.bmp 

And for Photos use AAAPHO.bmp 

After you have all the sprites It's time to plop them into the SmashGP character Editor. 

Step 4: CharEdit.exe  
Now Launch CharEdit.exe wherever you unzipped it to. This Program is what makes the character work. 

Here is a rundown of the Editor: Character Info: 

Weight - This is how light/heavy the character is. The heaver he/she/it is the harder it is for them to fall out 

of the ring and jump, however the opposite is true for light characters. 

Jumps - For balance this should be left on 2, however. If you’re making a multi-jump character along the 

lines of Kirby and Jigglypuff then feel free to raise it up. 

Name - This is the name displayed when selecting your character. 

Load Icon - This is the "lives" picture of you character displayed above percentage hurt. Must be an 8-bit 

BMP and must be 16x16 in resolution. A good and traditional idea for the Icon is a shot of the character's 

head. 

Load Photo - This is the picture you see while selecting a Character. The best Idea for this is to find a boxy 

picture of him or her you like. Then convert it to be 8-bit BMP. After that Open it in Irfanview and Select: 

Image>Resize/Resample. Only select Set new size, and the new size should be 48x48 pixels. 

Under the Character Info is the sound box. I haven’t gotten sounds to work correctly but I will update this 

when I do. 

Load Character - loads an already saved character (note: you must have all the BMP files used to make 

him in the same folder as the .chr file to load properly) 

Save Character - Saves the Character in a nice little .chr file. 



Exit - what do you think? (Doesn’t ask you to save changes!)Some things before I move onto moves: 

Speed bar: how fast the move will animate (1-2 is good most times) 

Load Frame(s): Loads the frames you’re going to use in that move. A good rule of thumb is to hold the 

Ctrl key and select all the sprites in that frame. If for some reason you load the wrong ones you'll have to 

set the Anims to 0 and hit Apply then reload them and the wrong sprites will disappear. 

Anims: how many Animations (sprites) are in the move. Should go up as you load them. 

Set Hit Point #1/#2 - I will explain what each hit point does in the move but to set it hit "set Hit Point #1 or 

#2" and click where on the sprite being displayed you'd like it to be.  

Crosshair: you'll notice there is a crosshair always displayed on your character. That tells you where the 

ground is so you don’t have feet sticking through. To change this click on the sprite where you'd like the 

crosshair to be.  

Apply button: after you load the frames and do everything, don't move on to the next move yet hit "Apply" 

Always hit "Apply" after editing a move, before moving onto the next! The Custom Projectile - When 

you launch CharEdit the projectile should also pop up. Don't close it even if you don’t want a projectile.  

Range is how far it goes. 50 is close range, 200 is long. 

Power is just like an attack 

Anims is how many Animations in it 

Load Frames loads the frames 

And smash counts as a smash attack. To the left of the Character info is the list of the moves. Although 

some are listed you don’t really know what each is for, do you? I'll tell you: 00 - Idle - When your 

character does nothing. Can be looped. Make sure to select the Hit Point 1, this will tell the game where to 

put an item the character is holding. 

01 - Walk - When you move left or right in the game but not to far. The X variable tells the games how far 

to move (100 is a good variable for this.) You should loop this for most normal sprites. 

02 - Run - When you slam the control stick left or right you move that direction fast, like you running... 

the X variable should be set to 200-300 traditionally. Loop should be used  

03 - Crouch - can be looped and is activated when you hold down while on the ground. 

04 - Jump 1 - When you hit up or the jump button. Can be looped. X and Y accel tell the game how the 

character moves in midair. Y should be negative (put a - in front of the number) and around -6000 to -

7000. X tells the game how much to the left and right he/she can move, 150 is a good number for this. 

05 - Jump 2 - The last jump your character has after you use your first one. Just like jump 1, except most 

people put the X and Y accel a little bigger (-8500 for Y and 170 for X) 

06 - Near Hole - When your character is near a gap where they can fall. Can be looped. 

07 - Jump Down - Activated when you hit down twice to go through platforms. No loop 

08 - Hanging - Activated when you are jumping to a platform and barley makes it. Can be looped. 

09 - Rolling - Do not loop. Used when you crouch and move left or right. X will tell game how far to 

move (use numbers in the thousands) 

10 - Braking - Frames should be reversed so it looks like they're turning around. No loop. 

13 - Turning - Activated when not moving then start moving in the opposite direction of what you're 

facing. No loop. 

14 - Run On Wall - Activated when you hit a wall while running, no loop.  

15 - Hit - Activated when damaged but not enough to fall down. No loop 

20 - Falling On Ground - when you’re knocked out in midair and begin to hit the ground. No loop 

21 - On Ground - When you’re knocked onto the ground. No loop 

22 - Getting Up - After you’re knocked to the ground and climb back up to your feet. No loop 

23 - Falling - When your Knocked out in midair. Can be looped 

24 - Dizzy - When you use too much of your shield (bubble) and it is destroyed. Can be looped 

25 - Caught - When the Opponent grabs a hold of you. Can be looped 



28 - Won - Activated during the Results Screen, and you win. Can be looped. 

29 - Lost - Activated during the Results Screen, and you lose. Can be looped. Now starts the attacks which 

are a bit different. Each button combination is an attack and you can set each attack to be a moving hit, 

throw projectile, simple hit, etc. So I'm going to tell you what each one does. Simple Move - DO NOT 

USE. This is what is used for none attacking moves, so change it (it's the default option) 

Simple Hit - A standard, none moving hit. X and Y define how far the enemy will move when hit (put in 

thousands if you want the enemy to fly away) the number you can put is limited by your characters weight. 

More weight means you can move the opponent farther, but lighter one cant hit the opponent as far. Power 

is how effective it is and here is a good rule for power: 500 = 3% added to their damage, you can gauge by 

that. Hit Point #1/#2 tells the game where the opponent must be to be hurt.  

Smash Hit. The Same as a Simple Hit except that everything can go twice as high! 

Catch Attempt - Used when you want to try to catch an object/person for move 50. You don't have to set 

move 50 to be a catch attempt. You could make it a secret super move. Hit Point # 1 Tells the game where 

the Object must be to try and catch it. Whatever you put in the power is how much damage is dealt if 

successful. 

Catching / Hammer Use - used for catching and using a hammer. Each frame must have a coordinate to 

place the person/hammer. 

Throw Fireball / Other - Used when you want your character to launch your custom projectile. The fastest 

you can set it for is 4000. The X accel is for making it go foreword, and -Y will make it fly up. Hit Point 

#1 tells the game where to place the projectile. 

Earthquake and Lightning Bolt - Not used right now. 

Moving Hit - Same as a simple hit except that the X and Y accel tell the game how to move YOU when 

you start the move. Hence the name "moving" hit. 

Move Hit Chain (->) - This is the same as a moving hit except now you have a new option (and no Hit 

Point #2). Under Next Move you select a number between 64 and 79. If this move is successful then your 

character will follow it up with this move. You can make large hit chains by continually linking them one 

after another. 

Pad - Hit Chain (->) - same as Move Hit Chain (->) except that you must choose a trigger action (button 

combination). Great for skill based hit chains. Now back to each move, but remember: for moves 30 -79 

you must choose what type of move. (on PSP: A = X, B = O)  

30 - A Running - Activated When Running and you hit A. 

31 - A Smash Running - Activated when running then pressing A instantly after. 

32 - A Jumping - Hitting A while jumping. 

33 - A Smash Jumping - Jumping and then Hit whatever Direction your moving and A. 

34 - A Smash Up Jumping - Jumping then Hit Up and A. 

35 - A Smash Down Jumping - Jumping then hit Down and A. 

36 - A Crouched - Hitting A while crouched. 

38 - A Reversed Smash Jumping - Hitting A and then the opposite direction you’re facing while jumping. 

40 - A Standing - Hitting A while Idle. 

41 - A Smash Standing - Hitting A and whatever direction you’re facing.  

42 - A Smash Up Standing - Hitting A and Up while Standing. 

44 - A Reversed Smash Standing - While Idle hit the opposite direction you’re facing and A.  

50 - R and A Catch Attempt - Used mostly for Catch Attempts, but you can set it for a Smash Hit or some 

super secret move. 

51 - Catching - If your Catch Attempt is Successful. 

60 - B - Simply hit B. 

61 - B Smash - Hitting B and whatever direction you’re facing. 

62 - B Smash Up - Hitting B and Up at the same time. 



63 - B Smash Down - Hitting Band Down at the same time. 

64 - used for Hit Chains 

65 - used for Hit Chains 

66 - used for Hit Chains 

67 - used for Hit Chains 

68 - used for Hit Chains 

69 - used for Hit Chains 

70 - used for Hit Chains 

71 - used for Hit Chains 

72 - used for Hit Chains 

73 - used for Hit Chains 

74 - used for Hit Chains 

75 - used for Hit Chains 

76 - used for Hit Chains 

77 - used for Hit Chains 

78 - used for Hit Chains 

79 - used for Hit Chains 

80 - Take Object - Used when you pick up and object. Hot Point #1 is where the object is while picking it 

up. 

82 - Throw Object - Throw Object in front of you. X and Y are how it will travel. Make Y negative for the 

object to go further. (remember X and Y should be in the thousands) 

83 - Throw Object Up - Same as throw object except you throw it up, a negative Y would be used to make 

it go up (in the thousands). 

84 - Throw Object Down - Same as throw Object down, just use a positive Y instead. 

85 - Use Object (Staff) - Used when the character has a Star Rod or Homerun Bat. X and Y define how the 

opponent will move when hit and Hit Point #1 is where the staff will be displayed on the last frame.  

86 - Use Object (Hammer) - THIS ANIMATION MUST HAVE 5 FRAMES, you will have to set where 

the hammer will be each frame , just like Catching. 

87 - Use Object (Gun) - For use of a gun like the ray gun, Hit Point #1 is where the gun will go. 

88 - Use Object (Flower) - Not used right now 

89 - Smash Object (Staff) - Just like 85 but the X and Y limits are 2 times as High. And there is the 

movelist!  Now that you have your character all animated in CharEdit click "Save Character" Save it as it's 

name (for simplicity)Sounds: 

I've finally gotten sounds working with the help of mATkEUpON. To do this you'll need a certain type 

of software, this one isn't free. Cool Edit Pro 2.1. That link is only the free trial. I have the pay 
for version (costs about $300). I wouldn't recommend buying it though. I got mine from my 
cousin because he does a lot of photo/sound editing. If you need sounds converted send me the 
ready-to-convert sounds to me.  Anyways Follow this guide if you have the trial version (if it supports 
everything I do, I'm not sure what the limitations are on the trial).Launch the program. Make sure you 

have the sounds you want ready. If you need to cut parts out this is how: 

Open the File you should see something like this: 



If you need to crop it drag over what 

needs to be deleted and right click>cut: 

After your sound is all tidy and ready 

you need to convert it to the right properties for SmashGP 

To do this you need to Select the Convert Sample Type: 

 
After you select this use these settings: 

Sample Rate: 22050 Hz 

Channels: Mono 

Resolution: 16 bit 

Like this: 



Now select OK.  Now your file is in the right 

format now hit Save As and save it as Windows PCM (*.wav).When naming the file keep it under 6 

characters like the BMPs files.  

Once again if you can't afford/find a copy/somehow obtain Cool Edit Pro 2.1 just Email me the files and 

I'll convert them for you. 

Step 5: Bmp2paK.exe  
You remember another program that came with that SmashEdit Zip you download a long time ago? 

Bmp2pak was it? Yeah.  Bmp2pak will convent the BMPs you used to be used in the game. Launch the 

program, when you see it make sure to select "use external palette" like this: 

 
Now Select Add files. Add all the files you used in CharEdit. But if you have more than 80 add the first 

80, then hit add files again and add the rest. Bmp2paK can only add 80 files at a time. When you’re done 

Hit "Save .pak" and save the Pak as the same name as your character file. And when it asks for the palette 

navigate to where you unzipped the SmashEdit zip. pal00.act came with the zip. 



 
That's what you’re looking for. 

After you save it you can now test it! 

Step 6: Ready, Set, Go!  
Place the .chr file in the SmashGP folder (or SmashGpsp or whatever you decided to call it, but not the 

one with the % at the end). and then make a Folding next to the .chr you just placed. Name the folder 

whatever the ,chr file is. now place the .pak in the new folder (it should have the name of the folder/.chr 

file). Now you may have this already done but if not, make a folder called Palette next to the .chr and the 

folder with the .pak in it. now copy that pal00.act into the palette folder. 

Now you should be al ready. Start up SmashGP and select your character! 

Extra Step 7: Re-Editing Your Character  
So you've played with your now character and you'd like to add/fix some things? No problem! Just make 

sure every time you re load the .chr file to have the BMPs used in the same folder. AND if you add change 

any of the BMPS you need to re-pak them in Bmp2paK. 

Final Thanks!  
Thanks to mATkEUpON for making this great game and Porting it to the PSP!  
PSPupdates Forums specifically this topic. 

Me for making this!  

Any question? If so please ask them in this thread.  

  

 


